Got awkward puppy photos?

All these new puppy posts have inspired me to go through old puppy photos. Was rummaging through the 'photo book' and found another odd photo or two of Beo as a puppy - a puppy going through the 'awkward' stages of growing no less.

I thought it might be fun to see if anyone else had some 'awkward' puppy photos laying around 🙂

"Before" and "After".

He was sporting some major dumbo ears, a helicopter tail, and wrinkles that would make Father Time look twice.
attachment_t_15968_0_beo-8-2012-2v2.jpg
attachment_t_15968_1_blahv2.jpg

Elliot is always a little awkward lol. The sleeping ones where taken a few days after I got him and the ones of the two of us were about a month ago LOL.
attachment_p_170592_0_elliotsleep1.jpg
attachment_p_170592_1_elliotsleep2.jpg
attachment_p_170592_2_ellirun2.jpg
attachment_p_170592_3_img_4192.jpg
attachment_p_170592_4_img_4195.jpg
attachment_p_170592_5_img_4197.jpg
attachment_p_170592_6_img_4199.jpg

The BRAT FB page had a Very Silly thread about Bs and tin hats…not a Happy Bunny...
attachment_p_170597_0_tin-hat-small.jpg

Haha, too cute and funny. I love that Elliot is draped over the golden - the perfect blanket? I think so.

The tin hat is excellent, as is his/her expression.

Butu is a boy…and I love it too - you can tell he is thinking "She's an Idiot, but why Involve Me?"

Reminds me of a quote I saw [not my own] while browsing an unrelated forum, something along the lines of:

"Maybe one day dogs will evolve to the point where they can defend themselves from our silly hats, but until that day comes I'm going to continue dressing my pugs up in stupid clothing…and there's not a thing they can do about it."

I never thought I would put clothing on my dog....and now and then I catch myself taking stupid photos with him in my jacket, or sunglasses, etc. . No costumes yet though thankfully... I do love the tin hat though, absolutely adorable. Teehee.

They are so patient with us.

Looks like your connection to Basenji Forums was lost, please wait while we try to reconnect.